Excel 2003: "Auto' Features & Formatting

AutoComplete

Compares the text that you are currently typing into a column and
completes the text for you. The list comes from the previous rows with no
blank ones. Right-clicking and using Pick From Drop-down List gives
similar results. If AutoComplete is not working, use Tools>Options and
look at the Edit tab. Make sure that Enable AutoComplete for cell values
is checked.

AutoFill

Once you begin entering it in, you can have a preexisting list, or custom list,
automatically finish filling in the cells. You can also AutoFill formulas.

To make a custom list, use Tools>Options and choose the Custom Lists

tab.

e Select NEW LIST.

e Start typing the new list in the List entries: box. Press the Enter key
after each item.

e C(Click on the Add button to add the list to the Custom Lists box.

e If you want to edit the list, click on the list and edit in the List entries:
box.

e If you want to delete the list, click on the list and click on the Delete
button. Click OK to the message about permanently deleting the list.

e Click OK to get out of the dialog box.

Options g If you have a long list that you
Color International Save Error Checking Speling Security h ave al ready Created i n o n e
i Calculation Edit: Gener 3 | Transition Custar Lists Chart . . .
location and you want it available

T TR— for other locations, select the list

Sunday, Monday, Tuesday, Wer H
Jan, Feb, Mar, Apr, May, Jun, 1 fl I’St.

January, February, March, April

Then use Tools>Options and
choose the Custom Lists tab.
If the cells already show up in the

Press Enter to separate lisk entries, “ImpOrt IiSt from Ce”S:” bOX, CIiCk
Imnport lisk From cells: sag1a$as21 Import I m po rt

The values should show up in the
o ][ = || “List entries:” box.
Click OK and use the list.
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AutoCorrect

Corrects common spelling errors as you type text into a cell. This option is
found in Tools>AutoCorrect Options>AutoCorrect. Choose what you
would like automatically corrected while you type.

If you have a long phrase or title that you type on a regular basis, you can
also use the “Replace text as you type” feature.

AutoCorrect: English (U.S.) @3] For example, you can type “csd”
AutoCarrect | AukoFormat As You Tvpe | Smart Tags In the “Replace” bOX’ and type
Shgw AutoCorrect Options buttons “COrVaIIIS SChOOI DIStrICt” In the
[¥] Correct T INitial CApitals - Wlth bOX, and CIICk on Add and
Capitalize First letter of sentences o K .
Capitalize names of days H
[¥] Correct accidental use of cAPS LOCK key ‘-‘rher)’ If you go to a Ce” and type
I e e el csd” and press Enter or leave
Fict e With: the cell, the “csd” should fill in
i el oo D with “Corvallis School District.”
o e * || Todelete an automatic
il S replacement, type the shortcut
chasgory category b . “ ”
——— into the “Replace:” box. After the
phrase shows up in the “With:”
C o J[ oo | box, click on Delete and OK.

AutoCalculate

In the status bar, view the total value of a range of cells that are selected. If

you do not see the value, go to Tools>Options and choose the View tab.

Make sure that Status Bar is checked.

e Values are Average, Count (Entries in Cells), Count Numbers,
Maximum, Minimum, and Sum.

e Select a range of cells.

e View the value presented in the status bar.

¢ Right-click in the status bar to change the value.

AutoSum

After selecting a range of cells and clicking the AutoSum button, the
calculation required to arrive at the sum is automatically entered into a
nearby cell. You can also choose a cell and click the AutoSum button. If
the AutoSum function guesses the wrong cells you want added, you can
correct it by selecting different cells.
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» Select a range of cells. -

e Click the AutoSum button. = The total value shows up in a nearby cell.
Or

Place the cursor in a cell near a range of numbers.

Click on the AutoSum button.

If the AutoSum function is incorrect, go to the correct cells.

Hold down the left mouse button to drag and select the correct range.

.-

You can also click on the dropdown [+
arrow next to this button to

automatically perform more Sy
You can automatically calculate the
Sum, Average, Count, Max, and Satlne
Min. Marx
Clicking on “More Functions” will get i
you to the “Insert Function” dialog -
box. Maore Functions. ..
AutoFormat
AutoFormat X] You can use
— Format>AutoFormat to
quickly format an existing
:
e = ! TN _ ° | range of cells.
Total 21 15 21 60 w.] | Select the range of cells
el that need formatting.
| | R =R A =T Use Format>AutoFormat
et 54 7 7 and choose a preexisting
South 8 7 ] 24
3 Total 21 18 __ 21 D format.
Cocills et 3 Click on Options and
an Feb Mar Total
East - 7 : h“ 5 . East ’ 7 : 7 5 t19 make any Ch?'nges' Only
West 8 4 7 17 ||est & 4 7 17 those formatting changes
South g 7 g 24 || South =3 7 9 24 . .
Total 21 18 1 B0 || Jotal 2118 21 B0 with a check in front of
List 2 List 3 v them will match the
Farmats to apply exam ple .
Murmber Font Alignment .
[+] Border [¥] Patterns [w] widthyHeight CIICk OK and see the
formatting in place.
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Changing Column Width and Row Height

If you see a row of pound signs (######) or a scientific notation (1.2E+08)
in the cell, the column is not wide enough to display the value contained in
that cell.

To change the column width, you can:

e Use Format>Columns>AutoFit Selection which adjusts the width of the
column to the widest entry. (If you add other entries later, the width may
need to be readjusted.)

e Double-click on the right border of the column heading to automatically
set the column width to the widest entry

To change the row height, you can:

e Use Format>Row>AutoFit to adjust the height of the row to the tallest
entry. (If you add other entries later, the height may need to be
adjusted.)

e Double-click the bottom border of the row to automatically set the row
height to the tallest entry

Formatting Text and Data including Merge and Center

After you have entered text and numbers into the Excel spreadsheet, you
can make multiple changes to present your information in the best fashion.
Some of these involve font size & style, color, and cell content alignment.

If you want a title to go across several columns, type the title in the left cell.
Select all the cells that include the distance for the title.

i
Click on the Merge & Center button. 2
Notice that in this example cell A1 is now enlarged to a width of 5 columns
& the text is centered. (When you merge cells, the cells to the right of the
first one, Cells B1, C1, D1, & E1, are inaccessible.)

: arial -0 - B I U|E | § % o E Arial -0 -| B I U |E = § o
A - & Here is a headline Al - A Here is a headline

A | B | © [ D F ] A | B [ ¢ T b | E F |
1 |Here is a headline 1 Here is a headline
2 — 2

m

Formatting Individual Characters in a Cell
You can format individual characters in a cell.
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e Double-clicking the cell and selecting individual characters to edit or
format.

e Select the character or characters you want to format by dragging the
mouse or holding down the Shift key while using the right or left arrow
buttons.

e Make the change to the text and press the Enter button.

Formatting Numbers

When formatting numbers in a cell or range, you can choose many
categories. The default option is usually General.

If you are typing dates & don't like the way that Excel is changing them, use
the Date category to choose the correct method for the document.

If Excel is treating an alphanumeric phrase as a mathematical expression
or a date, use the Text category to keep the alphanumeric entry exactly as
you typed it.

.0 .00
% * TH5 3.0

On the Formatting toolbar :
e The “Dollar Sign” button will change the number to a currency style with
a dollar sign to the left, separated 1,000’s with a comma, & 2 decimal

places.

e The “Percent” button will display the value as a percentage with 0
decimal places.

e The “Comma” button will display the value with 1,000’s separated by a
comma & 2 decimal places.

e The next 2 buttons will either increase or decrease the number of
decimal places.

Formatting Cells

Each cell can be changed individually or as part of a group.

e Select the cell or range of cells.

e Use Format>Cells and choose among several tabs—Number,
Alignment, Font, Border, Patterns, & Protection.
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In Format>Cells, under the Format Cells ?x

Alignment tab! you can: Mumber || Aignment} | Font | Border | Patterns | Protection
e Adjust both horizontal and Text aligrment Orientation
vertical alignment. Horizonkal: O
» Choose options such as left, e = e || '
right, centered, and justified Bottom 3 t Text —¢
in the drop down lists. o
e Choose to what degree you | "o R
want the text or numbers to [ shrink to fit 0 % Degrees
be slanted in the cell. RigEfﬁL?f cels
e Choose to have the text Text drection:
wrapped around, reduced to ot b
fit the cell, or merged to carry
over onto other cells. K __J [ Conce
In Format>Cells, under the Font tab, you can:
e Choose to change the font type and size. Bluc J]
e Choose have text or numbers shown in bold, italic, or ue,J.
underlined. Brown, N
e Choose to have characters shown as superscript, . _
subscript, or strikethrough. Cpeents

Choose a color for the characters in the cell.

In Format>Cells, under the Border tab, you can:

e (Choose where on the spreadsheet to have the border or lines outlining a
specific area.

e Change the style and color.

e The changes can be effective for a single cell or a range of cells,
depending on what is highlighted at the time.

In Format>Cells, under the Patterns tab, you can:
e Choose among options filling the cell’'s background.

Davienne Jacobson 6 June, 2006



e Choose a pattern and/or color.
A B | C [ D [ E

Local High School Magazine Sales
Students EE ] Y
Blue, A.
Brown, M.
Green, V.
Black, N. g

Total $862.08

5

$659.45 | $592.63

—

In Format>Cells, under the Protection tab, you can:
e Choose to keep certain cells locked or hidden.
e This is only effective when the spreadsheet itself has protection.

Format Painter .2

You can quickly copy formats between cells and objects.

e Select the cell that has the desired formatting.

e Click on the Format Painter (once to paint once, double-click to keep
the Format Painter on). Notice that the mouse cursor has turned into a
paintbrush and white plus sign.

e Paint by holding down the left mouse button & clicking into an individual
cell or dragging through many cells.

e To release the paintbrush, click on the Format Painter once.

Conditional Formatting

With conditional formatting, the format of information will change based on
criteria. You cannot use Conditional Formatting on cells that are protected.
To use conditional formatting, select a range of cells. Go to
Format>Conditional Formatting.
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Conditional Formatting

Condition |
[Calvaue s ~| [EEEEER—— | | = and | =
Preview of Format to use MiFarmat-Sat e
when condition is true: = ot

@ Add == | Delete. .. | (] 4 | Cancel |

Start with Condition1 and choose “Cell Value Is” or “Formula Is”. Then
choose if the value will be less, greater, equal to, between, etc. If it is
between, there will be places to enter both values. The value can been
typed in or chosen from another place in the workbook or another
workbook.

Format Cells E| Bl

l Border ] Patterns l
Faonk skyle:
iy J Reqular J J
iy Ttalic
EBold
J Biold Ikalic J J
Underline: Color:
| | — |
Effects Previewm
[+ Strikethrough
L AaBhCeyyiz
-
For Conditional Formatting wou can set Fonk Style,
IUndetling, Color, and Strikethrough, Clear
(04 | Cancel |

Click on Format and make formatting changes as appropriate. Click OK.
Once the first condition is done, click on Add>> and add an another

condition. Make sure that the conditions make sense and don’t contradict
each other.
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Conditional Formatting

Condition 1
|CEII Yalue Is j |greater than or equal ko j |III

Preview of format to use BB e T
when condition is krue: ¥

Condition 2

Y|

_Eomat..._|

m&j |Iess than ﬂ ||:| E
_Famat.._|

Presiew DF_Fprm_at ko use AaBbCeYyIz
when condition is krue;

@ Add = | Delete, .. | I | Cancel |

If you click on the Delete button, you can choose which condition to delete.

Go To Special E|E|

Select
" Comments " Row differences
" Constants " Column differences
" Formulas (" Precedents
[~ " Dependents
[v {+
[V fi
Delete Conditional Fo... E]g| [V " Last cel
" Blanks " visible cells anly

Select the condition(s) to delete:
" Current region  © Condikional Farmats

[ iC :
e " Current array " Data walidation
[ Condition 2 ;
" Objects fo Al
[ Condition 3 e
Same

Ik | Cancel | (04 | Cancel |

If you want to see which cells have conditional formatting, click any cell.
Use Edit>Go To and click on Special. Choose Conditional formats and
click All under Data validation.

If you want to see cells that have conditional formatting identical to another

specific cell, click that cell. Use Edit>Go To and click on Special. Choose
Conditional formats and click Same under Data validation.
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