Excel 2003: Pivot Tables

A pivot table is a good way to summarize large amounts of data. The
information can be looked at in ways that are easier than in a worksheet.
The information can also be manipulated separately from the large
worksheet.

Before creating a pivot table from data, make sure that the spreadsheet

data is organized in an understandable way.

1. The first row of the spreadsheet should contain column headings.

2. All column headings should be unique.

3. There should be no completely empty rows or columns or any
separation of relevant data.

4. There should be no subtotals or grand totals. If there are, take them off
using Data>Subtotals>Remove All>OK.

5. Each column should contain only one type of data. There should be no
cells containing both text and computational numbers.

Creating a Pivot Table

Once the data is ready, select any cell in the area that you want to use in
the pivot table.

Use Data>Pivot Table and Pivot Chart Report.

The wizard will show up.

In Step 1, choose if the data is other than in Excel. You can also choose if
you want a PivotChart report.

PivotTable and PivotChart Wizard - 5tep 1 of 3

Where is the data that wou wank bo analyze?
%) Microsoft OFFice Excel lisk or database!

) External data source

() Multiple consolidation ranges

wWhat kind of report do vwou want bo create?
%) PivotTable
() PivokChart report (with PivotTable report)

[ wext> |[ Ensh |

Click Next. Step 2 will choose the data range.
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Where is the data that you want ko use?

Range: HEL2E

[ Cancel ][ < Back ][ Mext = ][ Finish ]

Click Next if Excel has guessed correctly. Otherwise, modify the range.

In Step 3, you can choose to have the pivot table on a new worksheet or on
a worksheet that is already there.

PivotTable and PivotChart Wizard - Step 3 of 3

‘here do vou want to put the PivotTable report?

(%) Mews workshest
() Existing workshest
| E

Click Finish to create vour PivotTable report,

[ Layout... H Options. .. ] [ Cancel ” < Back. ]

You could create the layout and choose options at this point, but it is easier
to do it on the worksheet with the field list and toolbar. Click Finish.

If you would usually want these choices, you can use Data>Pivot Table and
Pivot Chart Report and then click on Finish.

A new worksheet is created with the pivot table structure.
There is a PivotTable Field List and a Pivot Table toolbar.

A | B | ¢ | b | E [ F [ & H [ [ 0 [ kK [ L J
1 Drop Page Fields Here =
2
3 | Drap Calumn Fields Here
4

5 | Q PivotTable Field List v X
E % Drag items to the PivotTable report

7

E ? [ Last Mame

ER = (] First Mame

o o | Drop Data ltems Here joce

|11 | @ (] Department

£ o E|Salary

3] ©

[14] T

[ 15| 2 &dd Ta | [Row Area -
1B M

17

16

| 19 | PivotTable

% pivotTable ~ | 7 | = #= | ¢ | ¢[3] 24 [2] =
22
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The column headings have become fields. If the PivotTable Field List is not
showing, click somewhere in the pivot table structure or click on the “Show

Field List button.

The PivotTable toolbar helps you improve the data analysis. If the
PivotTable toolbar is not showing, click in the pivot table or click on
View>Toolbars>PivotTable.

Parts of a Pivot Table

The Row Fields show summaries vertically in rows.

The Column Fields show summaries horizontally across columns.

The Data Items show summaries of numerical data.

The Page Fields show summaries for a single item or all items at once.

Fields that are dropped or added to one location can easily be moved to
another location, depending on the analysis wanted. When fields are added
to the pivot table, the field names are formatted bold in the Field List.

Using the Row or Column Field

Here is an example of salary totals by department. Salary was added to
Data Items. Department was added to Row Fields or Column Fields.
A

| B ¢c | o | E [ F
1
2 PivotTable Field List v x I
3 JSum of Salary Drag items ko the PivokTable report
4 Depgn.ment.[v Total Surm ofSaIarv|Depar1mentm
| 5 |Administration | 136000 ] Last Name IAdministration Development | Froduction Sales [Grand Tatal
6 |Development | 250000 | First Name Total 1L 136000 250000 139000 185000] 710000
7 |Production 135000 e
g |Sales 185000 EI 9 T = | PivotTable Field List ¥ X
9 |Grand Total 710000 EI Department Drag ikems ko the PivolTable report
Salar
ﬂ EI Y [E] Lask Name
% EI First Mamne
-P.dd To | |Row Area v [ Ao
ﬁ - EI Department
ﬂ =] Salary
15 - x
15 I 7= 11 = = |
——— | PivokTable » | 22 @z | ¢ ) @ (=
17 Srelane l jﬂl — _l = | | i‘ Row Area “
18

To remove the field from an area, drag it away from the pivot table area.
You will see a red X when you are removing the field.

Using the Page Field and Showing All or Some Data

Here is an example of Age as the Row Field, Salary as the Data ltem, and
Department as the Page Field. First there is the total for all departments
and then for just the Development department.
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Clicking on the dropdown arrow next to (All) shows a box. Choose the
request “page” view and click OK. The summaries change accordingly.

Department £l
Sum of Salary
Age [~ [Tatal
22| 19000
25| 22000  |pivetTable Field List - x
gg giggg Drag items to the PivotTable report
31] 25000 [F] Last Mame
- I [=] First Mame
35| 62000 A
36| 30000 H Age
A1 40000 [F] Department
42] 45000 ] salary
49) 24000
a0) 62000
51| 50000 Row irea v
25| 24000
a6 41000
B2 55000
Grand Total 710000

Al
Administration
Development
Production

Sales

( ok,

] [ Cancel

]

Department

|Development [Z]

Sum of Salar\rc]_

Ane [=[Total
28 41000
29 49000
31 29000
42 45000
49 24000
a0 E2000

Grand Total 250000

You can also choose to have the different page fields show data, each

having its own worksheet.

Click on the Page field, Department in this example.

Click on the Pivot Table toolbar>Show Pages. Click OK.
The separate worksheets are immediately created in front of the pivot table
worksheet. Each worksheet is actually a fully functioning pivot table that
has been modified to show a specific page with information ready for

reporting or printing.

4 Administration ¢ Development / Production / Sales £ Sheetl /

Using Both Row and Column Field and Showing Partial Data

Here is an example of cross-
tabulation, using Age as a Row field
and Department as a Column field.
There are totals at the end of each
row and column as well as the
Grand Total.
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Surn of Salary [Depatment [+]

Age + |Administration Oevelopment  Production Sales Grand Total
2 18000 19000
2 22000 22000,
28 41000 25000 GE000;
=] 45000 43000 24000,
H 29000 29000,
33 25000 19000 47000,
35 52000 62000,
36 30000 30000,
4 40000 40000,
42 45000 45000,
49 24000 24000,
50 52000 62000,
a1 50000 50000,
55 24000 24000,
jaia] 41000 41000,
52 55000 55000,

Grand Total 136000 250000 139000 185000 710000
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In the Row field, you can choose which categories to show. The default is
to show all. To only show some, click in the Show All box to clear all the
boxes. Choose which ones you want to show and click OK. For example, if
you wanted only data for those whose age was in the 30’s. Notice that the
Administration department is missing because there is no one in their 30’s
in that department. In addition, the grand total changes accordingly.

Ane -
-~

Sum of Salary |Department [ |
Age [=]Development  Production Sales Grand Total
k)l 29000 29000
; 33 28000 19000 47000
! — 34 E2000 £2000
[ Cancel 36 30000 30000
Grand Total 29000 53000 51000 168000

In the Column field, you can choose which categories to show. The default
is to show all. To only show some, click in the Show All box to clear all the
boxes. Choose which ones you want to show and click OK. For example, if
you wanted only data for those in the Production department. Notice that

only the relevant ages are showing. In addition, the grand total changes.
Denartrent [« | |
|

v Productian Sum Df53|arvchEpanment [T
[ 5aes e [« [Production | Grand Tatal
a3 28000 28000
a6 30000 20000
41 40000 40000
la] 41000 41000
Srand Total 139000 139000

Updating Information

Sometimes information in the worksheet will change. Records will be
revised or deleted. If information in the original worksheet changes, the
pivot table will not automatically update the analysis.

Click anywhere on the report.
Use Pivot Table toolbar>Refresh Data.

Adding another record at the bottom of the worksheet will not automatically

show up on the pivot table. However, adding a record to the middle of the
worksheet will show up.
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Changing the Sorting Order and Showing Top or Bottom Values

The data can be sorted in ascending or descending order. Also just the top
or bottom specific number of values can be shown.

Click on the field heading or a cell in the list.

Click on the Pivot Table toolbar>Pivot Table.

Click on Sort and Top 10.

To change the sorting order, choose Ascending or Descending and click
OK.

To show only some of the values, click On, choose between Top or Bottom,
and choose the maximum number of values that will show.

This example shows the bottom four salaries with the ages ascending.
When the field is filtered by top or bottom, the heading font turns blue.

When the filtering is off, the heading font returns to its original color.
[

Surn of Salary [Department [~ |

Age ¥ |Administration  Development Production Sales Grand Total
22 19000 19000
25 22000 22000
42 24000 24000
55 24000 24000

Grand Total 41000 24000 24000 g2000

PivotTable Sort and Top 10 3

Field: Age
AukoSort opkions Top 10 AutoShow

) Manual {you can drag items to rearrange them) O off
: : ®on

Showe: | Bokbam v | |4 £

Using Field: Using Field:

Age e Sum of Salary w

[ QK ][ Cancel ]

v vl adn
L

Changing the Summary Function of Data

Although the sum of the values is the default, there are other automatic
functions. They are Count (which counts the number of data values, same
as COUNTA in the worksheet), Count Nums (which counts the number of
data values that are numeric, same as COUNT in the worksheet), Average,
Max, Min, Product, StDev, St Devp, Var, and Varp.

To change the summary function, click on the data area.

Click on the Pivot Table toolbar>Field Settings.

Choose another function in the Summarize by: box and click OK. Notice the
label now says “Count of Salary” and that the data fields are counts.
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Formatting Numbers in the Data Area

The numbers in the data area can be formatted at any time.

Click anywhere in the data area.

Use Pivot Table toolbar>Field Settings.

Click on the Number button.

Make choices about number types and how many decimal places.
Click OK and then OK to change the number format.

Renaming and Formatting Field Headings

The boxes that identify the field names can be relabeled.
Click the field name box.

Clear out the old name and type in a different name.
Press Enter on the keyboard or click in another cell.

The field name can be formatted in different font, font size, font color, bold,
italic, and underlined. The field name cell can have different alignment and
fill color. However, it is a good idea to wait until the end to make formatting
changes. Click the field name box.

Click on the formatting toolbar to change the field name box.

Formatting the Report

It is better to wait until the end before formatting the report.
Click anywhere on the report.

Use Pivot Table toolbar>Format Report.

Choose an AutoFormatting design. Click OK.

To change the format design, click anywhere on the report.
Go back to Format Report. Choose another design. Click OK.

To go back to the original pivot table formatting, choose PivotTable Classic.
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Printing the Report

The report can be printed at any stage of the analysis. The dropdown
arrows do not show when the report is printed.

Using Outer and Inner Row Fields

More than one field can be dragged into a drop area of a pivot table.
Fields can be used more than once, even in the same drop area.

If a pivot table has more than one row field, it has an inner and outer row. A
pivot table can only have one inner row, the one closest to the data.
However, it can have more than one outer row.

|  Here the Department field gggﬂa;fm 5;'3[% Age[Tleal
Sum of Salary was added ’[O the Ieft Of Administration 22| 19000
Department [ |Age [ [Total : : 25 22000
Administration 221 19000 the Age fleld' NOt|Ce that 29( 45000
25l z2000f  gubtotals have been 51| 50000
29| 45000 Developrment 28( 41000
51| 50000 added. 29| 49000
Administration Count 4 31| 29000
Administration Max 50000 A2 45000
Development | 28| 41000 To remove Subtotals, use ;_13 EQSSS
29| 49000 . .
31| 29000 Pivot Table toolbar>Pivot  Fogimion 33| 2r0m0
a2 =00l table. Click on Subtotals 3o soort
£0| G200 to take them off. 56| 41000
Development Count 7 Sales 2a8| 25000
Development Max £2000 33( 19000
Production 53] 28000 35| 62000
38 qnnnn - o ag Annn

Grouping and Ungrouping Data

Less detailed summaries can be shown. Information can be grouped.
Click anywhere in the data that needs to be grouped.

Use Pivot Tables toolbar>Group and Show Detail>Group.

Choose how to group information. Click OK.

To ungroup data, use Pivot Tables toolbar>Group and Show
Detail>Ungroup. The information is ungrouped.

Surn of Salary |
Department | = |Age [+|Total .
Adrninistration|22-31_| 86000 Grouping X
42-51 | 50000 Ao
Development |22-31 | 115000
42-51 |131000 Skarting at:
Production 3241 98000 Ending at: 6z
5262 | 41000 o o
Sales 22-31 | 25000 Eit
3241 | 81000
52-62 | 79000 Lok ][ cancel
Grand Total 710000
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Hiding and Showing Detail
To decrease the amount of information showing, details can be hidden.

Click anywhere in the field that needs to be Sum of Salary [

hidden. For example, if several departments ﬁzﬁnﬁ:{;ﬁ;‘:g}*ge FE‘;‘SDD
need to have hidden data, select them all. Development 250000
Use Pivot Tables toolbar>Group and Show iDEE o JeElLY
Detail>Hide Detail. e oo

To get the information back, select all the relevant headings and use Pivot
Tables toolbar>Group and Show Detail>Show Detail.

Using Custom Calculations

There are custom calcuations included in the pivot table. They are
Difference, % Of, % Difference From, Running Total in, % Of Row,% Of
Column, % Of Total, and Index.

To use an included calculation, use Pivot Tables toolbar>Field Settings.
Click on the Option button.
Choose a calculation in the Show data as: and click OK.

| PivotTable Field @
Sum of Salary 5 feld:  5al
BERERTTER ekl Total Nc-ur-:e |e alary
Administration 22| 2.68% ame: | &
2[5 107 curmarias b
: 2UmmarizZe 0y,
2 3% b
al 7 0ae | -
Developrment 28] 577% rf\qverage
29 B.90% 8
k) 4-DBC£ g‘rlgduct
421 B.34% Caunk Nums v
gg ;‘?23’ Show data as:
= % of total
Fraduction 33 354% oo v
B 4.23%
41 f.63% Lask Marme
6] A77%
Sales 28] 3462%
33| 26B8%
35| 873%
flaf g 2 200

GETPIVOTDATA Function

If an equal sign is typed in a cell outside the pivot table and a cell inside the
pivot table is selected, the GETPIVOTDATA function is activated. This will
get the information from the cell even if the report layout changes.

If you do not want to use this function in a formula outside the pivot table,
type the cell address rather than clicking on the cell.
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